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NEW QUESTION 1
You have a table that contains data relating to exam candidates and their associated scores.
You need to visualize the exam data by separating the data into quartiles. The visualization must display the mean score and must identify any outliers.
Which type of chart should you use?

A. line
B. histogram
C. pie
D. box and whisker

Answer: D

Explanation: 
https://support.office.com/en-us/article/create-a-box-and-whisker-chart-62f4219f-db4b-4754-aca8-4743f6190f0

NEW QUESTION 2
You use a workbook query to import a table named Customers that contains a column named CustomerName. CustomerName has names in the format of
Lastname, Firstname.
You need the CustomerName column to contain names in the format of Firstname Lastname. A space must separate Firstname and Lastname.
Which two commands should you use? To answer, drag the appropriate fields to the correct areas. Each field may be used once, more than once, or not at all.
You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
 Split Column By Delimiter
 Merge Columns

https://support.office.com/en-us/article/split-a-column-of-text-power-query-5282d425-6dd 0-46ca-95bf-8e0da9539662
https://support.office.com/en-us/article/merge-columns-power-query-80ec9e1e-1eb6-4048-b500-d5d42d9f0

NEW QUESTION 3
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have a query named Queryl that retrieves the user information from two Excel files. One of the Excel files does not contain location information. A sample of
the data retrieved by the query is shown in the following table.

You need to ensure that values in UserName are unique. The solution must ensure that the locations are retained. A sample of desired output is shown in the
following table.

Solution: You select the UserName and Location columns, and then you click Keep Duplicates. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 4
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario
You have six workbook queries that each extracts a table from a Microsoft Azure SQL database. The table are loaded to the data model, but the data is not loaded
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to any worksheets. The data model is shown in the Data Model exhibit. (Click the Exhibit button.)
Your company has 100 product subcategories and more than 10,000 products.

End of repeated scenario.
You have a PivotChart that uses Manufacturer as the axis and the sum of SalesAmount as the values. You need to ensure that only the top 10 manufactures
appear in the chart.
What should you do?

A. Change the format of the SalesAmount field.
B. Create a calculated column.
C. Configure the Value Filters.
D. Summarize the SaleAmount field by Max.

Answer: C

Explanation: 
https://www.extendoffice.com/documents/excel/1963-excel-pivot-table-filter-top-10.html 

NEW QUESTION 5
You create an Excel workbook named SalesResults.xlsx. You create a workbook query that connects to a Microsoft SQL Server database and loads data to the
data model. You create a PivotTable and a PivotChart.
You plan to share SalesResults.xlsx to several users outside of your organization.
You need to ensure that the users can see the PivotTable and the PivotChart when they open the file. The data in the model must be removed.
What should you do?

A. Run the Document Inspector.
B. Save the workbook as an Excel Binary Workbook (.xlsb).
C. From Query Editor, open the Data Source Settings and delete the credentials.
D. Modify the source of the query.

Answer: C

NEW QUESTION 6
You have a workbook query that gets a table from an Excel workbook. The table contains a column1. In the query, you configure Column1 to use a Data Type of
Whole Number.
You refresh the data and find several errors in Column1. You discover that new entries in the table contain nonnumeric characters.
You need to ensure that when the data is imported, any fields that contain nonnumeric values are set 1. What should you do from Query Editor?

A. Select the table and click Keep Errors.
B. Select the column and click Replace Values...
C. Select the column and click Remove Errors.
D. Select the column and click Replace Errors...

Answer: D

NEW QUESTION 7
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Your company has a data analyst who uses Microsoft Power BI Desktop to create a data model and several reports.
The data analyst publishes the reports to the Power BI service.
You need to create a PivotTable in Excel that uses the data model created by the data analyst. The solution must prevent the data from being imported into Excel.
What should you do first?

A. From powerbt.com, select the repor
B. From the File menu, click Save as.
C. From Excel, create a new query that uses the Data Catalog.
D. From powerbi.com, select the report From the File menu, click Download report.
E. From powerbi.com, select the report and click Analyze in Excel.

Answer: D

NEW QUESTION 8
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario.
You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A
sample of the data is shown in the Data Sample exhibit. (Click the Exhibit button.)
Data Sample exhibit:

The data model is shown in the Data Model exhibit. (Click the Exhibit button.)

The tables in the model contain the following data:
 DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or

revenue are recorded for that day. Total Hours and Total Revenue column.
 Workshops have a list of all the workshops and the current and previous workshop managers. The format of the Workshop Manager column is always

Firstname Lastname. A value of 1 in the IsLatest column indicates that the workshop manager listed in the record is the current workshop manager.
 RepairTypes has a list of all the repair types
Dates has a list of dates from 2015 to 2018

End of repeated scenario.
You create the column chart shown in the Pivot Chart exhibit. (Click the Exhibit button.)
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You need to ensure that the month axis is displayed chronologically. What should you do?

A. In the model, configure the Sort By Column setting for [Month] as [MonthID].
B. In the model, configure the Sort By Column setting for (Month) as [Date].
C. In PivotTable Fields, add [MonthID] to the Legend area.
D. In PivotTable Fields, add [Date] to the Legend area.

Answer: B

NEW QUESTION 9
You have a KPI named Goal that calculates the sales from the previous year and multiplies the sales by 1.1. You need to modify Goal to multiply the sales from
the previous year by 1.15.
What should you do?

A. From Power Pivot, modify the measure.
B. From the properties of the KPI, modify the KPI base field.
C. From Power Pivot, create a new calculated column, and then modify the KPI.
D. From the properties of the KPI, modify the absolute value.

Answer: A

NEW QUESTION 10
You need to create a PivotChart that has a filter as shown in the following exhibit.

What should you do first?

A. From the model, create a measure.
B. From Query Editor, create a function.
C. From Query Editor, create a parameter.
D. From the model, create a hierarchy.

Answer: A

Explanation: 
References:
https://support.office.com/en-us/article/measures-in-power-pivot-86484821-a324-4da3-803b-82fd2e5033f4

NEW QUESTION 10
You open C:\Data\Data,xlsx m Excel.
When you attempt to publish the file to Microsoft Power BI, you receive the following error message: "We couldn't publish to Power BI. Make sure your workbook is
saved as an Excel file (.xlsx or .xlsm) and is not password protected.*
You need to ensure that you can publish the file to Power BI. What should you do first?

A. Decrypt the workbook.
B. Disable iterative calculation for the workbook.

The Leader of IT Certification visit - https://www.certleader.com



100% Valid and Newest Version 70-779 Questions & Answers shared by Certleader
https://www.certleader.com/70-779-dumps.html (117 Q&As)

C. Copy the file to a network share.
D. Add a digital signature to the workbook.

Answer: A

Explanation: 
With Excel 2016, you can publish your Excel workbooks right to your Power BI site, where you can create highly interactive reports and dashboards based on your
workbook’s data. You can then share your insights with others in your organization.
Before we go any further, there are few things to keep in mind:

 Before you can publish to Power BI, your workbook must be saved to OneDrive for Business.
 The account you use to sign in to Office, OneDrive for Business, and Power BI must be the same account.
 You cannot publish an empty workbook or a workbook that doesn’t have any Power BI supported content.
 You cannot publish encrypted or password protected workbooks, or workbooks with Information Protection Management.
 Publishing to Power BI requires modern authentication be enabled (default). If disabled, the Publish option is not available from the File menu.

https://docs.microsoft.com/en-us/power-bi/service-publish-from-excel

NEW QUESTION 11
You have an Excel workbook query that loads data to a worksheet and the data model. You need to ensure that the data is refreshed whenever you open the
workbook.
What should you do?

A. From the File tab, click Option, and then modify the Data option.
B. From the File tab, click Options, and then modify the General options.
C. From the Data tab, click Queries & Connections, and then edit the properties of the query.
D. From the Power Pivot model, modify the Table Behavior setting.

Answer: C

Explanation: 
https://support.office.com/en-us/article/refresh-an-external-data-connection-in-excel-2016-for-windows-152417

NEW QUESTION 16
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have the following data.

You need to retrieve a list of the unique ProductName entries.
Solution: Create a PivotTable that uses the ProductName field in the Rows area. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 21
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it As a result, these questions will not appear in the review screen.
You have an Excel workbook that contains a table named Table1. A sample of the data in Table1 is shown in the following table.

You need to create a PivotTable in PowerPivot as shown in the exhibit.
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Solution: You create a hierarchy named Products that contains ProductCategory,
Solution: You create a measure named Products the uses the DataTable DAX Function. You add a PivotTable. You drag products to the Rows field. You drag
Price to the Values field.
Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 23
You have the following table.

You plan to use [Month Name] as the axis in a PivotChart.
You need to ensure that whenever [Month Name] is used in a chart, the months are displayed chronologically be default.
What should you do?

A. Sort the [Month Name] column by [Month Name].
B. Change the Data Type of [Month Name] to Date.
C. Sort the [Month Name] column by [Month Name].
D. Add a calculated column named [ID] that use the [Month Name] & [Month Number] DAX formula

Answer: D

Explanation: 

The Leader of IT Certification visit - https://www.certleader.com



100% Valid and Newest Version 70-779 Questions & Answers shared by Certleader
https://www.certleader.com/70-779-dumps.html (117 Q&As)

References:
https://gasperkamensek.wordpress.com/2013/04/16/sorting-months-chronologically-and-not-alphabetically-in-a-

NEW QUESTION 28
You have a measure that is used by a KPI.
You need to display the output of the measure in a cell in your workbook. Which Excel function should you use?

A. CUBEVALUE
B. VLOOKUP
C. CUBESET
D. LOOKUP

Answer: A

Explanation: 
https://support.office.com/en-us/article/cubevalue-function-8733da24-26d1-4e34-9b3a-84a8f00dcbe0 https://powerpivotpro.com/2010/06/using-excel-cube-
functions-with-powerpivot/

NEW QUESTION 31
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario
You have six workbook queries that each extracts a table from a Microsoft Azure SQL database. The tables are loaded to the data model, but the data is not
loaded to any worksheets. The data model is shown in the Data Model exhibit.

Your company has 100 product subcategories and more than 10,000 products. End of repeated scenario.
You need to create a simplified view of the workbook for some users. The simplified view must only display data from FactSales, DimProduct, and DimDate.
What should you do in the data model?

A. Click Hide from Client Tolls for all the tables except FactSales, DimProduct, and DimDate.
B. Create a new perspective.
C. Modify the Table Behavior settings for FactSales, DimProduct, and DimDate.
D. Add the columns from FactSales, DimProduct, and DimDate to the Default Field Set.

Answer: A

NEW QUESTION 32
You have a model that contains data relating to corporate profits. The model contains a measure named Profit.
You need to create a PivotTable to display the Profit measure in three different formats by using the Show Value As feature. The PivotTable must produce the
results shown in the following table.
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How should you configure the Show Value As feature for % Profit of Annual Total and % profit of Grand Total? To answer, select the appropriate options in the
answer area.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
% Profit of Annual Total: % of Parent Total
% Profit of Grand Total: % of Column Total
https://support.office.com/en-us/article/show-different-calculations-in-pivottable-value-f ields-014d2777-baaf-480b-a32b-98431f48bfec

NEW QUESTION 36
You have a data model that has the following tables.

You create a PivotTable. The data displayed in the PivotTable is shown in the following table.

You need to ensure that the correct data is displayed. What should you do?

A. Modify the workbook connections
B. Configure the PivotTable Options
C. Modify the relationships
D. Refresh the data connection
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Answer: C

NEW QUESTION 41
You have a table that contains the following data.

You need to create a PivotTable as shown in the exhibit. (Click the Exhibit button.)

How should you configure the PivotTable? To answer, drag the appropriate fields to the correct areas. Each field may be used once, more than once, or not at all.
You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
Box 1: Columns: Customers Box 2: Rows: Products
Box 3: Values: Quantity Box 4: Filters: Country

NEW QUESTION 44
You need to create a combo chart to display the count of orders by month and profit by month as shown in the exhibit. (Click the Exhibit tab.)

How should you configure the combo chart? To answer, select the appropriate options in the answer area. NOTE: Each correct selection is worth one point.
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A. Mastered
B. Not Mastered

Answer: A

Explanation: 
Order Count:Stacked columnNo Profit:LineYes
http://www.excel-easy.com/examples/combination-chart.html

NEW QUESTION 47
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result these questions
will not appear in the review screen.
You have two Microsoft SQL Server database servers named Production1 and Test1. Production1 contains the same tables as Test1, but only a subset of the
data.
You add Test1 as a data source, and you select 10 tables. You configure several transformations. You need to connect the model to the tables in Production1. The
solution must maintain the existing
transformations.
Solution: From Query Editor, you edit the source of each table query. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 48
You have the PivotTable shown in the following exhibit.
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You need to display only rows in the PivotTable in which the sum of LineTotal is greater than 100. What should you do?

A. From Row Label, configure a Label filter.
B. Add a slicer for LineTotal and select the values from the slicer.
C. From Row Label, configure a Value Filter.
D. Add LineTotal to the Filters area of PivotTable Field
E. Configure the Filters value.

Answer: B

NEW QUESTION 52
From a workbook query, you import a table that has the following data.

You need to configure the table to appear as shown in the following table.

What should you do?

A. From the Format menu, click Trim.
B. From the Format menu, click Clean.
C. From the Split Column menu, click By Delimiter.
D. From the Extract menu, click Last Characters.

Answer: A

NEW QUESTION 53
You have a table that contains sales data.
You need to create a Pivot Table that will display the sales by country as shown in the following exhibit.

What should you use to display the icons?

A. a measure
B. conditional formatting
C. data validation
D. a KPI

The Leader of IT Certification visit - https://www.certleader.com



100% Valid and Newest Version 70-779 Questions & Answers shared by Certleader
https://www.certleader.com/70-779-dumps.html (117 Q&As)

Answer: B

NEW QUESTION 58
You have the Excel worksheet shown in the exhibit.

You need to transform the data by using Query Editor. What should you do first?

A. From the Data tab, click From Table/Range.
B. From the Data tab, click Flash Fill.
C. From the Data tab, click Consolidate.
D. From the Insert tab, click Store.

Answer: A

NEW QUESTION 63
You have an Excel workbook that contains two tables named User and Activity. You plan to publish the workbook to the Power BI service.
Users will use Q&A in the Power BI service to perform natural language queries.
You need to ensure that the users can query the term employee and receive results from the User table. What should you do before you publish to Power BI?

A. From the Power Pivot model, edit the synonyms.
B. From PowerPivot Settings, modify the language options.
C. From PowerPivot Settings modify the categorization options.
D. From Workbook Connections, add a connection.

Answer: B

NEW QUESTION 68
Your company has sales offices in several cities.
You create a table that represents the amount of sales in each city by month as shown in the exhibit.

You need to ensure that all values lower than 250 display a red icon. The solution must ensure that all values greater than 500 display a green icon.
Solution: You create a measure, and then define a target value. Does this meet the goal?

A. Yes
B. No

Answer: B

NEW QUESTION 72
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer chokes, but the text of the scenario is the same in each question in this series.
Start of repeated scenario
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You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A
sample of the data is shown in the Data Sample exhibit.
Data Sample exhibit:

The data model is shown in the Data Model exhibit. (Click the Exhibit button.)

The tables in the model contain the following data:
 DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or

revenue are recorded for that day. Total Hours and Total Revenue column.
 Workshops have a list of all the workshops and the current and previous workshop managers. The format of the Workshop Manager column is always

Firstname Lastname. A value of 1 in the IsLatest column indicates that the workshop manager listed in the record is the current workshop manager.
 RepairTypes has a list of all the repair types
 Dates has a list of dates from 2015 to 2018

End of repeated scenario.
When you attempt to create a relationship between DailyRepairs and Workshops, Power Pivot generates the following error message: “The relationship cannot be
created because each column contains duplicate values. Select at least one column that contains only unique values”.
You need to ensure that you can create a valid relationship between the tables. What should you do?

A. In the Power Pivot model, change the data type for Workshop[ID] to General
B. In the workbook query for Workshops, add an index column
C. In the Power Pivot model, change the Table Behavior setting for Workshops
D. In the workbook query for Workshops, filter [IsLatest] to equal 1

Answer: C

Explanation: 
References: https://msdn.microsoft.com/en-us/library/hh560544(v=sql.110).aspx

NEW QUESTION 74
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have two Microsoft SQL Server database servers named Production1 and Test1. Production1 contains the same tables as Test1. but only a subset of the
data.
You add Test1 as a data source, and you select 10 tables. You configure several transformations. You need to connect the model to the tables in Production1. The
solution must maintain the existing
transformations.
Solution You create a new connection to Production1, and then you import the tables. Does this meet the goal?

A. yes
B. No

Answer: B

NEW QUESTION 75
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
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stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it As a result, these questions will not appear in the review screen.
You have an Excel workbook that contains a table named Table1. A sample of the data in Table1 is shown in the following table.

You need to create a PivotTable in PowerPivot as shown in the exhibit.

Solution: You create a hierarchy named Products that contains ProductCategory, ProductSubCategory, and ProductName. You add a PivotTable. You drag
Products to the Rows field. You drag Price to the Values field.
Does this meet the goal?

A. Yes
B. No

Answer: A

Explanation: 
Hierarchy Products that contains ProductCategory, ProductSubCategory, and ProductName
https://www.tutorialspoint.com/excel_power_pivot/excel_power_pivot_hierarchies.htm

NEW QUESTION 80
You create a new workbook and add a table to a data model. The data is shown in the following table.

You need to create a visualization as shown in the following exhibit.
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Which three actions should you perform in sequence? To answer, move the appropriate actions from the list of actions to the answer area and arrange them in the
correct order.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
 Create a Pivot Table. Create a measure.
Create a Power View Report

NEW QUESTION 83
You have a workbook query that loads data from a table in a Microsoft Azure SQL database. The table has a column named LineTotal. The following is a sample
of the data in LineTotal:
• 40
• 1
• 999
• 7658
• 883432
You need to ensure that when you load the data to the model, LineTotal is set as currency. What should you do from Query Editor?

A. Configure the Data Type
B. Round the column.
C. Split the column by characters.
D. Split the column by delimiter.

Answer: A

NEW QUESTION 84
You have the following table named SalesOrder Detail in a model.

You need to calculate the sum of SalesTotal for all the rows that have a quantity greater than 1.

A. Mastered
B. Not Mastered

Answer: A
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Explanation: 
CALCULATE(SUMX(‘SalesOrdersDetail’[SalesTotal]),‘SalesOrderDetail’[Quantity] > 1)

NEW QUESTION 86
You have a measure named SalesGrowth that calculates the percent of sales growth. The measure uses the following formula.
([Total Sales Current Year] - [Total Sales Last Year]) / [Total Sales Last Year]
Total Sales Current Year is a measure that calculates the sales from the current calendar year. Total Sales Last Year is a measure that calculates the sales from
the previous calendar year.
You need to create a KPI that displays a red icon when the sales growth is less than last year. What should you use to define the target value?

A. an absolute value of 0
B. the Total Sales Current Year measure
C. an absolute value of 100
D. the Total Sales Last Year measure

Answer: D

NEW QUESTION 89
You have a query that retrieves the following data.

You need to configure the query to ensure that the data appears as shown in the following table.

What should you do?

A. From the Transform tab, use the sum function on the Vendor_ID column
B. Group by Vendor_ID and add a SUM aggregation
C. Unpivot the table on the Vendor_ID column
D. Pivot the table on the Vendor_ID column

Answer: B

NEW QUESTION 92
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result, these questions will not appear in the review screen.
You have two Microsoft SQL Server database servers named Production1 and Test1. Production1 contains the same tables as Test1, but only a subset of the
data.
You add Test1 as a data source, and you select 10 tables. You configure several transformations. You need to connect the model to the tables in Production1. The
solution must maintain the existing
transformations.
Solution: From Query Editor, you configure the Data source settings. Does this meet the goal?

A. Yes
B. No

Answer: A

NEW QUESTION 93
You have a workbook query that loads the following table
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You pivot the table on the Key column by using Value as the values column, and you receive the results shown in the following table.

You need to ensure that the data appears as shown in the following table.

What should you do?

A. Change the aggregate value function of the pivot.
B. Select the ID column, and then click Unpivot Columns
C. Change the Data Type of the Value column.
D. Delete the Picoted Column ste
E. Select the Key column, and the click UnpivotColumns.

Answer: B

Explanation: 
References:
https://support.office.com/en-us/article/unpivot-columns-power-query-0f7bad4b-9ea1-49c1-9d95-f588221c7098

NEW QUESTION 97
You have a PivotChart template named Template1. You add a PivotChart to a worksheet.
You need to apply the template to the PivotChart. What should you do?

A. On the Design tab, click Change Chart Type.
B. On the Format tab, click Format Selection.
C. Right-click the chart and then click PivotChart Options.
D. Right-click the chart and then click Format Chart Area.

Answer: A

Explanation: 
 Click the chart
 On the Charts tab, under Change Chart Type, click Other, and then under Templates, click the chart template that you created.

https://stackoverflow.com/questions/17386777/how-to-apply-a-saved-chart-template-to-an-existing-chart

NEW QUESTION 98
You have a workbook query that retrieves data from a table named Users. Users contains a column named PhoneNumber. The following is a sample of the data in
PhoneNumber.
514 555 0169
1 (11) 500 555-0122
128 555-0148
819 555-0186
1-996-555-0192
+1 138-555-0156
556-555-0192
You need to create a custom column that contains the data in PhoneNumber in the format of 999-999-9999. The following is a sample of the desired data.
514-555-0160
500-555-0122
128-555-0148
819-555-0186
996-555-0192
138-555-0156
556-555-0192
How should you complete the Query Editor formula? To answer, drag the appropriate values to the correct targets. Each value may be used once, more than once,
or not at all. You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.
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A. Mastered
B. Not Mastered

Answer: A

Explanation: 
Text.Replace(Text.End([Phone],12)," ","-")

NEW QUESTION 102
You create an Excel workbook named SalesResults.xlsx. You create a workbook query that connects to a Microsoft SQL Server Database and loads data to the
data model. You create a PivotTable and PivotChart.
You plane to share SalesResults.slsx to several users outside of your organization.
You need to ensure that the users can see the PivotTable and the PivotChart when they open the file. The data in the model must be removed.
What should you do?

A. Modify the source of the query.
B. From Query Editor, open the Data Source Setting and delete the credentials.
C. Run the Document inspector.
D. Save the workbook as an Excel Binary Workbook (xlsx)

Answer: A

Explanation: 
References:
https://support.office.com/en-us/article/data-source-settings-power-query-9f24a631-f7eb-4729-88dd-6a4921380

NEW QUESTION 105
Note: This question is part of a series of questions that use the same scenario. For your convenience, the scenario is repeated in each question. Each question
presents a different goal and answer choices, but the text of the scenario is the same in each question in this series.
Start of repeated scenario.
You are creating reports for a car repair company. You have four datasets in Excel spreadsheets. Four workbook queries load the datasets to a data model. A
sample of the data is shown in the Data Sample exhibit. (Click the Exhibit button.)
Data Sample exhibit:
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The data model is shown in the Data Model exhibit. (Click the Exhibit button.)

The tables in the model contain the following data:
 DailyRepairs has a log of hours and revenue for each day, workshop, and repair type. Every day, a log entry is created for each workshop, even if no hours or

revenue are recorded for that day. Total Hours and Total Revenue column.
 Workshops have a list of all the workshops and the current and previous workshop managers. The format of the Workshop Manager column is always

Firstname Lastname. A value of 1 in the IsLatest column indicates that the workshop manager listed in the record is the current workshop manager.
 RepairTypes has a list of all the repair types
 Dates has a list of dates from 2015 to 2018

End of repeated scenario.
You create a measure named Average Revenue Per Hour that calculates the average revenue per hour. You need to populate a cell in a worksheet to display the
Average Revenue Per Hour where Repair Type is
Engine.
Which Excel formula should you use?

A. =CUBEMEMBER(“ThisWorkbookDataModel”, “[DailyRepairs]. [Avg Revenue Per Hour]”,CUBEMEMBER (“ThisWorkbookDataModel”, “[Dimensions]. [Repair
Type]. [Engine]”))
B. =CUBEVALUE(“ThisWorkbookDataModel”, “[Measures]. [Avg Revenue Per Hour]”, CUBEMEMBER (“ThisWorkbookDataModel”, “[Dimensions]. [Repair
Type]. [Engine]”))
C. =CUBEMEMBER(“ThisWorkbookDataModel”, “[DailyRepairs]. [Avg Revenue Per Hour]”, CUBEMEMBER (“ThisWorkbookDataModel”, “[RepairTypes].
[Repair Type]. [Engine]”))
D. =CUBEVALUE(“ThisWorkbookDataModel”, “[Measures]. [Avg Revenue Per Hour]”, CUBEMEMBER (“ThisWorkbookDataModel”, “[RepairTypes]. [Repair
Type]. [Engine]”))

Answer: B

Explanation: 
 References:
https://support.office.com/en-us/article/cubevalue-function-8733da24-26d1-4e34-9b3a-84a8f00dcbe0
https://www.tutorialspoint.com/advanced_excel_functions/advanced_excel_cube_cubemember_function.htm

NEW QUESTION 106
You have 20 workbook queries that load 20 CSV files to a local computer.
You plan to send the workbook and the 20 CSV files to several users. The users will store the files in various location.
You need to ensure that the users can change the path to the CSV files in the queries as quickly as possible. What should you do from Query Editor?

A. Merge all the querie
B. Edit the source of the first query.
C. Create a paramete
D. Modify the source of each query to use the parameter.
E. For each query, create a new query that uses a referenc
F. Modify the source of each new query.
G. Append all the querie
H. Edit the source of the first query.

Answer: B
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Explanation: 
https://www.howtoexcel.org/power-query/how-to-parameterize-your-power-query/ 

NEW QUESTION 107
You have two queries named Client and Invoices. A sample of Client is shown in the following table.

A sample of Invoices is shown in the following table.

You need to create a new table that has the following information.

Which join kind should you use?

A. Inner
B. Left Outer
C. Right Anti
D. Left Anti

Answer: B

Explanation: 
https://www.excelguru.ca/blog/2015/12/16/merge-tables-using-outer-joins-in-power-query/

NEW QUESTION 112
You have a table named Sales that has three columns named Region, Country, and SalesAmount. You create a PivotTable as shown in the following exhibit.

You need to ensure that the PivotTable appears in three columns as shown in the following exhibit.

What should you do?

A. On the Design tab, click Report Layout and then click Show in Compact Form.
B. Move Country from the Rows area to the Columns area.
C. Move Country from the Rows area to the Values area.
D. On the Design tab, click Report Layout and then click Show in Tabular Form.

Answer: D

NEW QUESTION 116
You have a data model that contains a table named SalesOrders has four columns named Orderld, SalesAmount, OrderDate, and Territory.
You plan to create a PivotChart that will display the percentage of SalesAmount for each Territory. You need to create a measure to calculate the percentage of
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sales of each territory.
How should you complete the DAX formula? To answer, drag the appropriate value to the correct targets. Each value may be used once, more than once, or not at
all. You need to drag the split bar between panes or scroll to view content.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
SUM([SalesAmount) / ALL(SalesOrders) /(FILTER , ALL(SalesOrders))

NEW QUESTION 121
You merge several CSV files by using Query Editor.
You need to remove all the leading whitespaces and all the non-printable characters from a column.
What should you do to achieve each task? To answer, drag the appropriate actions to the correct goals. Each action may be used once, more than once, or not at
all. You may need to drag the split bar between panes or scroll to view content.
NOTE: Each correct selection is worth one point.

A. Mastered
B. Not Mastered

Answer: A

Explanation: 
Box 1: From the Extract menu, click Trim Box 2: From the Extract menu, click Clean

NEW QUESTION 124
You have a model that contains data relating to corporate profits. The model contains a measure named Profit.
You need to create a PivotTable to display the Profit measure in three different formats by using the Show Value As feature. The PivotTabte must produce the
results shown in the following table.

How should you configure the Show Value As feature for % Profit of Annual Total and % Profit of Grand Total? To answer, select the appropriate options in the
answer area.
NOTE: Each correct selection is worth one point.
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A. Mastered
B. Not Mastered

Answer: A

Explanation: 
% Profit of Annual Total: % of Parent Total
% Profit of Grand Total: % of Column Total
https://support.office.com/en-us/article/show-different-calculations-in-pivottable-value-fields-014d2777-ba

NEW QUESTION 128
You have a workbook query that uses an Excel data source. The data source contains the following table.

You need the data to appear as shown in the following table.

How should you transform the data from Query Editor? To answer, select the appropriate options in the answer area.
NOTE: Each correct selection is worth one point.

A. Mastered

The Leader of IT Certification visit - https://www.certleader.com



100% Valid and Newest Version 70-779 Questions & Answers shared by Certleader
https://www.certleader.com/70-779-dumps.html (117 Q&As)

B. Not Mastered

Answer: A

Explanation: 
Box 1: User and UserID Box 2: Unpivot Columns
References:
https://support.office.com/en-us/article/unpivot-columns-power-query-0f7bad4b-9ea1-49c1-9d95-f588221c7098

NEW QUESTION 132
You have a table in Power Pivot model that is loaded from a Microsoft SQL Server database.
The source table has four columns named ID, Price, Quantity, and Total. Total is derived by multiplying Price and Quantity. ID is a unique row identifier.
You need to minimize the amount of memory used to load the mode. The solution must ensure that you can create visualizations based on Price, Quantity, and
Total.
What should you do?

A. Replace the Total column by using a measure.
B. Replace the Total column by using a calculated column.
C. From Query Editor, remove duplicate rows from the table.
D. Move the Total column to a lookup table.

Answer: A

Explanation: 

References:
https://support.office.com/en-us/article/create-a-memory-efficient-data-model-using-excel-and-the-power-pivot-

NEW QUESTION 135
You have a table named Sales that has three columns named OrderDate, OrderNumber, and SalesAmount. You need to create the PivotTable as shown in the
following table.

What should you use?

A. KPIs
B. sparklines
C. conditional formatting
D. banded rows

Answer: A

NEW QUESTION 137
Note: This question is part of a series of questions that present the same scenario. Each question in the series contains a unique solution that might meet the
stated goals. Some question sets might have more than one correct solution, while others might not have a correct solution.
After you answer a question in this section, you will NOT be able to return to it. As a result these questions
will not appear in the review screen. You have the following data.

You need to retrieve a list of the unique ProductName entries.
Solution: Create a PivotTable that uses the ProductName field in the Values area. Does this meet the goal?

A. Yes
B. No
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Answer: B

NEW QUESTION 142
......
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